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1.

IntroductionIntroductionIntroduction

Introduction

ArcGIS, the most widely used GIS software in the world, is an integrated collection of
software for compiling, visualizing, analyzing, and presenting geographic information. This
lab exercise is intended to familiarize you with ArcMap, one component of the ArcGIS
collection. ArcMap lets you create and interact with maps. In ArcMap, you can view, edit
and analyze geographic data. Your task it to produce a readable and visually pleasing map of
Sweden and its neighboring countries following the given instructions.

2.2.2.

2.

WorkingWorkingWorking

Working

withwithwith

with

ArcMapArcMapArcMap

ArcMap

GettingGettingGetting

Getting

startedstartedstarted

started

The files you will use during this lab are located as the following zip file:

http://www.infra.kth.se/courses/AG2411/IntroArcGIS.zip

Download the file to your own folder. Once you have copied the file, right click it and choose
Extract All. Follow the procedure to extract the files to your own folder.

Start ArcMap by clicking the Windows Start button and then navigate to:
All Programs –> ArcGIS –> ArcMap.

ArcMap will ask you what you would like to start with. Choose a New Empty Map and press
OK. Now ArcMap has started with a new empty map and should look like Figure 1.

Figure 1. Start ArcMap with a new empty map.
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Geographic information is displayed on a map as layerslayerslayers

layers

. Each layerlayerlayer

layer

represents a particular
type of feature such as cities, streams, lakes, or highways. Layers are listed in the ArcMap
tabletabletable

table

ofofof

of

contentscontentscontents

contents

, the white rectangle on the left of the screen, and displayed in themapmapmap

map

viewviewview

view

,
the bluish rectangle on the right part of the screen in Figure 1.

The tabletabletable

table

ofofof

of

contentscontentscontents

contents

lists all the layers on the map and shows what the features each layer
represent. The check box next to each layer indicates whether the layer is currently displayed
in the map view or not.

Layers can be further organized into datadatadata

data

framesframesframes

frames

. A data frame simply groups the layers that
you want to display together. Each datadatadata

data

frameframeframe

frame

is listed at the top of the table of contents as
"Layers", but you can change the name to something more meaningful. You may want to add
more data frames when you want to compare layers side by side or create inserts and
overviews.

When a map has more than one data frame, one of them is the active data frame. The activeactiveactive

active

datadatadata

data

frameframeframe

frame

is the one you're currently working with. When you add a new layer to a map, it
is added to the active data frame. You can always tell which data frame is active because it's
highlighted on the map and its name is shown in bold text in the table of contents (see the
example in Figure 2).

Figure 2. Layers, table of contents, data frames and map view.
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ArcMap can work with different types of geographic data. One of the most commonly used
data types is shape file (with extension .shp), a vector data representation. Geographic
features in vector format are represented as points, lines or polygons.

AddAddAdd

Add

datadatadata

data

to your map view by either pressing the Add Data button or selecting File ->
Add Data. Look in your own directory and add the shape file with country boundaries
(Country_Boundaries.shp). If your directory is not listed, add it by using the Connect To

Folder button . In the map view you will see a map of Sweden and its neighbouring
countries. In the table of contents you will see that you have one layer named
Country_Boundaries. Add other layers to your map by using the same procedure and
importing all the shape files that you have in your working directory (major cities, rivers,
water bodies, and streets and railroads). You can turn a layer on and off by checking and
unchecking the box next to the layer's name in the table of contents.

Below the name of each layer there is a colour legend of the features shown in this layer. You
can turn this off and on by clicking on the + or – sign next to the layer’s name. You can
change the colour of a legend by clicking on the legend.

The orderorderorder

order

ofofof

of

thethethe

the

layerslayerslayers

layers

in the table of contents defines the order in which they are displayed.
The layer at the bottom of the tabletabletable

table

ofofof

of

contentscontentscontents

contents

is displayed at the bottom of a map and the
layer at the top of the tabletabletable

table

ofofof

of

contentscontentscontents

contents

is drawn on top of all other layers. Thus it is wise to
put the layers that form the background of your map, such as the ocean, at the bottom of the
table of contents. Try moving the country boundaries layer to the top of the list and see how
the other layers disappear behind it. Now move it back down to the last.

ArcMap provides two different ways to view a map: a data view and a layout view. When you
want to browse or work with the geographic data on your map, choose data view. Layout
view should be used when you are preparing your map to hang on the wall, put in a report, or
publish on the Web. You can choose between the two views by selecting View -> Data view
or View -> Layout View from the menu. Try this and then return to data view.

MovingMovingMoving

Moving

aroundaroundaround

around

thethethe

the

mapmapmap

map

As you work with a map, you can easily change how you view the data it contains. When you
are browsing a map, you may want to pan and zoom around the data to investigate different
areas and features.

ZoomingZoomingZooming

Zooming

: Click the Zoom-In button or Zoom-Out button on the Tools toolbar.
Move the mouse pointer over the map display and click once to zoom around a point.
Alternatively, click and drag a rectangle defining the area you want to zoom-in or zoom-out.

PanningPanningPanning

Panning

: Click the Pan button on the Tools toolbar. Move the mouse pointer over the
map display and click and drag the pointer.

You can move back and forward one display by clicking the Back or Forward
Extent buttons on the Tools toolbar. Try this.

You can also zoom to the extent of a layer: right-click the layer or layers you want to zoom to
in the table of contents, then click Zoom To Layer. Or you can zoom to the full extent of your
map by choosing View -> Zoom Data -> Full Extent from the menu.
SavingSavingSaving

Saving

youryouryour

your

workworkwork

work
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You save a map as a document and store it on your hard disk. If you have not saved the map
before, you will need to name it with a name that adequately describes its contents. ArcMap
automatically appends a file extension (.mxd) to your map name. In general, it is a good idea
to save your map periodically while editing it just in case something unexpected happens.

You can save the map by either pressing the Save button on the Tools toolbar or
choosing File -> Save from the menu.

The data displayed on a map is not saved with it. Map layers reference the data sources in
your GIS database. This helps to keep map documents relatively small in size. If you plan to
distribute your map to others, you need to give them access to both the map document and the
data your map refers to.

ExploringExploringExploring

Exploring

datadatadata

data

ononon

on

thethethe

the

mapmapmap

map

Sometimes just looking at a map is not enough. You need to query data to solve problems.
ArcMap allows you to explore the data on the map and get the information you need. You can
explore data in various ways. For example, you can:
· point to features to find out what they are,
· find features that have a particular characteristic or attribute,
· examine all the attributes of a particular layer or
· measure distances on the map.

IdentifyingIdentifyingIdentifying

Identifying

featuresfeaturesfeatures

features

by pointing to them: click the Identify button on the Tools toolbar.
Click the mouse pointer over the map feature you want to identify. The features in all visible
layers under the pointer will be identified. Do this by clicking on Stockholm and see what
happens. Now click on Gotland (be careful not to click on Visby).

ViewingViewingViewing

Viewing

aaa

a

layer'slayer'slayer's

layer's

attributeattributeattribute

attribute

tabletabletable

table

: in the table of contents, right-click the layer for which you
want to display the attribute table (do this for Country Boundaries). Click Open Attribute
Table and observe what happens. Explore the table.

Question 1: Which country on the map is landlocked?

FindingFindingFinding

Finding

featuresfeaturesfeatures

features

withwithwith

with

particularparticularparticular

particular

attributesattributesattributes

attributes

: Click the Find button on the Tools toolbar.
Click the Features tab. Type the string you want to find in the Find text box. Click the In
layers dropdown arrow and click the layer you want to search. Uncheck Find features that are
similar to or contain the search string if the string must match exactly. Search for the string in
all fields, in a specific field, or in the primary display field. Click Find. Mark all found
features in the list of the Find window by pressing Ctrl while clicking on them with the mouse.
Right click on them and select them. Use the identify feature procedure to see which features
you found. Zoom in if necessary or hide/display the layers that might mislead you when
trying to identify features.

Question 2: Which rivers in the area are navigable?

MeasuringMeasuringMeasuring

Measuring

distancedistancedistance

distance

: first you need to set the correct distance units for your data frame.
Right-click on your data frame (“Layers”) and choose Properties. Choose the General tab and
set the Display units to kilometres. Click OK.
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Now click the Measure button on the Tools toolbar. Use the mouse pointer to draw a line
representing the distance you want to measure. The line can have more than one line segment.
Double-click to end the line. The distance is displayed on the grey bar on the lower left side of
your window. Try measuring distances between various features on the map. Use the identify
features procedure first in order to see which features (cities, rivers, lakes) you are using as
your measuring points.

Question 3: What is the distance between Helsinki and Oslo if you measure it via Stockholm?

SymbolisationSymbolisationSymbolisation

Symbolisation

andandand

and

colourscolourscolours

colours

When you first display your layers in the map view, ArcMap assigns colours randomly to the
layers. Sometimes you could end up with red rivers and yellow lakes. Your features are not
labelled either, so you may have to use the identify feature procedure in order to locate where
Oslo is, for example. In order to make your map a real map, you need to adapt the colours of
the features, choose the correct symbols for the features and add the labels on the map.

These can be done by editingeditingediting

editing

thethethe

the

propertiespropertiesproperties

properties

ofofof

of

eacheacheach

each

layerlayerlayer

layer

. Open the properties window for a
layer by right clicking on the layer’s name in the table of contents and then selecting
Properties.

All the layers you are currently working with show unique features, i.e., using single
symbol/color for cities, countries, lakes, etc. You may want to, however, display a particular
layer using several colours (for example, different colours for different countries), while
display others with the same colour (e.g., blue colour for all rivers). This can be done by
showing categorized data in the property window.

DisplayingDisplayingDisplaying

Displaying

thethethe

the

datadatadata

data

withwithwith

with

oneoneone

one

colorcolorcolor

color

:
- In the table of contents, right-click the layer you want to change symbol/color and click
Properties.
- Click the Symbology tab.
- Click on the large button representing the symbol you want to change and choose an
appropriate symbol for it. Or if you do no’t like any preset symbols, choose the colour and
other properties of the feature. Then click OK.

Edit your map so that your roads, rivers and water bodies get an appropriate colour.

DisplayingDisplayingDisplaying

Displaying

thethethe

the

datadatadata

data

withwithwith

with

severalseveralseveral

several

colorscolorscolors

colors

:
- In the table of contents, right-click the layer you want to display with several colors and
click Properties.
- Click the Symbology tab.
- Click Categories. ArcMap automatically selects the Unique Values option.
- Click the Value Field dropdown arrow and click the field that contains the values you want
to map.
- Click the Color Scheme dropdown arrow and choose a color scheme that you like.
- Click Add All Values. This adds all unique values to the list. Alternatively, click the Add
Values button to choose which unique values to display. Then click OK.

Edit your map so that the countries are drawn in different colours. Choose a colour scheme
you like the most.
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Now your map looks better, but there is still something missing - the labels. Generally,
labellinglabellinglabelling

labelling

is the process of placing descriptive text onto or next to features on your map. In
ArcMap, labeling refers specifically to the process of automatically generating and placing
descriptive text for map features. A label is a piece of text on the map that is dynamically
placed and whose text string is derived from one or more feature attributes. In ArcMap, label
positions are generated automatically, labels are not selectable and you cannot edit the display
properties of individual labels.

To display labels for a layer, you simply specify the attribute or attributes of the feature you
want to base your labels on - for example, a street name or soil type - and then turn labelling
on. ArcMap then automatically places labels on or near the features they describe. You can
also control the font, size, and color of the text to help differentiate labels for different types
of features. A map of Europe, for example, could have both country and major city labels,
each displayed with a different text symbol. When you turn on dynamic labelling, ArcMap
places as many labels on the map as possible without any overlap. In areas where features are
tightly clustered together, some features may not be labelled. As you zoom in on your map,
more labels will dynamically appear.

LabellingLabellingLabelling

Labelling

all features in a layer:
In the table of contents, right-click the layer you want to label and click Properties. Click the
Labels tab. Check Label Features. Click the Label Field dropdown arrow and click the field
you want to use as a label. Click OK. You can turn the labelling off by right-clicking on the
layer in the table of contents and unchecking the Label Features.

In the Labels tab you can also select the style for your labels. You can specify the colour, font
and size of your labels by editing the Text Symbol or using the Pre-defined Label Style. Try
this.

Edit your map so that you choose different labelling for each of the four features, i.e.,
countries, lakes, rivers, cities. Do not label streets and railroads. Play with styles until you
find your favourite combination.

ChangingChangingChanging

Changing

thethethe

the

coordinatecoordinatecoordinate

coordinate

systemsystemsystem

system

ofofof

of

youryouryour

your

mapmapmap

map

You may have noticed that the shape of Sweden is rather different from the one you knew.
The reason is that this map was a subset of a world map which uses GCS_WGS_1984, a
coordinate system that is suitable for world maps. Now you will change it to a coordinate
system that is suitable for a map of Sweden.

In the table of contents, right click on the ‘layers’ (or Map of Sweden if you renamed it) data
frame and choose Properties. The data frame’s current coordinate system is
GCS_WGS_1984. In the Select a coordinate system box, click on the plus sign next to
Predefined. Click on the plus sign next to the Projected Coordinate Systems, the plus sign
next to Continental, then the plus sign next to Europe.

The projected coordinate systems for Europe are listed. You will select an equal-distance
projection. Click Europe Equidistant Conic. The details of the projection appear in the
Current coordinate system box. Examine the details and click OK.
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Compare this map with the one in GCS_WGS_1984 coordinate system and write down your
observations.

AddingAddingAdding

Adding

mapmapmap

map

elementselementselements

elements

tototo

to

youryouryour

your

mapmapmap

map

Adding mapmapmap

map

elementselementselements

elements

is the final step of making your map. North arrows, scale bars, scale
text, title and legend are examples of such elements.

North arrows indicate the orientation of the map. Scale bars provide a visual indication of the
sizes of features and distances between features on the map. You can use a scale bar to
represent the scale of your map. A scale bar is a line or bar divided into parts and labelled
with its ground length, usually in multiples of map units such as tens of kilometers or
hundreds of miles. If the map is enlarged or reduced, the scale bar remains correct. You can
also represent the scale of your map with scale text. Scale text indicates the scale of the map
and of features on the map. Scale text tells a map reader how many ground units are
represented by a map unit, for example, "one centimeter equals 100,000 meters."

A legend tells a map reader which symbol is used to represent which feature on a map.
Legends consist of examples of the symbols on the map with labels containing explanatory
text. When you use a single symbol for the features in a layer, the layer is labelled with the
layer's name in the legend. When you use multiple symbols to represent features in a single
layer, the field you used to classify the features becomes a heading in the legend, and each
category is labelled with its value. Legends have patches that show examples of the map
symbols. By default, the legend patches are points, straight lines, or rectangles that match the
map symbols.

To add any of the map elements, you have to be in the layoutlayoutlayout

layout

viewviewview

view

(not the data view!).

AddingAddingAdding

Adding

aaa

a

NorthNorthNorth

North

arrow:arrow:arrow:

arrow:

- Click the Insert menu and click North Arrow.
- Choose a North arrow that you like.
- Click OK.
- Click and drag the North arrow into place on your map.
- Optionally, resize the North arrow by clicking and dragging a selection handle.

AddingAddingAdding

Adding

aaa

a

scalescalescale

scale

bar:bar:bar:

bar:

- Click the Insert menu and click Scale Bar.
- Choose a scale bar that you like.
- Click OK.
- Click and drag the scale bar into place on your map.
- Optionally, resize the text on the scale bar by clicking and dragging a selection handle.
- You can change the units on the scale bar by right-clicking it and editing the units in its
Properties.

The scale text can be added in a similar way as the scale bar. Try it.

AddingAddingAdding

Adding

aaa

a

legendlegendlegend

legend

:
- Click the Insert menu and click Legend. The Legend Wizard appears. If this wizard doesn't
appear, wizards have been turned off. When wizards have been turned off, a default legend
will be immediately added to your layout. You can double-click this legend to change its
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properties. If you would prefer to use the Legend Wizard when you insert a legend, you need
to turn wizards back on again. Choose Options from the Tools menu and in the dialog that
appears choose the Application tab and check the 'Show wizards when available' box.
- By default, all the layers on the map will appear as legend items in the legend. To remove a
legend item, click it, then click the left arrow button.
- Use the up and down arrow buttons to order the legend items.
- Click Next.
- Type a title for the legend.
- Set the text color, font, and size as desired.
- Click Next.
- Click the Border dropdown arrow and click a border.
- Click the Background dropdown arrow and click a background.
- Click the Drop Shadow dropdown arrow and click a drop shadow.
- Click Next.
- Click a Legend Item in the list to modify the symbol patch.
- Set the Patch properties as desired.
- Click Next.
- Set the spacing between legend elements by typing a value into the appropriate box.
- Click Finish.

AddingAddingAdding

Adding

aaa

a

titletitletitle

title

tototo

to

aaa

a

mapmapmap

map

:
- Click the Insert menu and click Title.
- Type a title for the map.
- Click and drag the title into place on your map.
- Modify the appearance of the title text by right-clicking on the title and editing its Properties.

AddingAddingAdding

Adding

texttexttext

text

tototo

to

aaa

a

mapmapmap

map

:
- Click the Insert menu and click Text. A text box will appear in the centre of your screen.
- Type the text.
- Click and drag the text into place on your map.
- Modify the appearance of the text by right-clicking on the text and editing its Properties.

Add the north arrow, scale, legend and title to your map. Edit their appearance and layout
until you like the finished map. Add your name and the date of production to the map.

ExportingExportingExporting

Exporting

thethethe

the

finishedfinishedfinished

finished

mapmapmap

map

Now you can export the map in a variety of formats. To export the map as an image file (a
.jpg or .tiff) you should choose File -> Export Map from the menu.
If you want to create a pdf, do not try to export it with ArcMap. Pdfs created with ArcMap do
not have all the information embedded. What you can do instead is that you print the map
choosing PDFcreator as your printer and follow the instructions that appear on the screen.
This will not actually print your map, but create a pdf of it in your disk space.

3.3.3.

3.

ReportReportReport

Report

You don’t have to write any report for this exercise. Export your map as a pdf file and show
the map and the answers to the three questions in the text to the teacher before the end of the
lab.
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